読者です 読者をやめる 読者になる 読者になる

Ruby1.9インストール

Ruby1.9を使わなくてはならない用がでてきたのでやっとの事でインストール。
MacPorts使ったら簡単。

はじめにとりあえずアップデート。

$ sudo port -d sync
$ sudo port -d selfupdate

肝心のRuby1.9のインストール

$ sudo port -d install ruby19

これでOK。

$ /opt/local/bin/ruby1.9 -v
ruby 1.9.1p243 (2009-07-16 revision 24175) [i386-darwin10]

そういえばPATHも通してなかったので通した。

$ export PATH=$PATH:/opt/local/bin

これで'ruby1.9'というコマンドでRuby1.9が使える。
インストール時に'nosuffix'というvariantもあるみたいだけど、自分で混乱してしまいそうなのでしばらくこれで使って困ったらその時また考えよう。